CentOs6.5 自带的cmake版本太老了,新一点的包都不能编译,像这次想装个lw-qq,在别的linux上像ubuntu、openSUSE、fedora等都是一件很简单的事,但是到centos上就成了一件很复杂的事情,首先就是cmake版本太低,需要先升级一下。

在这之前可能还需要安装gcc,这个我在先前解决各类软件的时候貌似已经解决掉了。

获取cmake 2.8.12源码包

cd /root/Downloads/
wget http://www.cmake.org/files/v2.8/cmake-2.8.12.1.tar.gz

解压cmake 2.8.12源码包

tar -xvzf cmake-2.8.12.1.tar.gz

编译并安装

cd cmake-2.8.12.1
./bootstrap
gmake
gmake install

检查安装是否成功

cmake --version

若安装成功,则会显示以下信息:

cmake version 2.8.12.1

你可能感兴趣的内容
CentOS 6.5下Git服务器搭建 收藏,2037 浏览
0条评论

selfly

交流QQ群:32261424
Owner