纯粹发发牢骚!!!

在使用了一段时间CentOS之后,发现centos的一些库和包实在太老了,很多需要的软件都装不上,连想到墙外去看看都得升级一下python,源码下来编译安装等很多都不支持,大把的时间总是花在升级它原有的库和包上,实在弄烦了。

或许有人会说越折腾不是越能学习吗,但是你要知道折腾的也得分是啥东西,整天升级库,升级包,源里自带的也老,网上到处找,千篇一律,都是眼泪啊!

其实最主要的还是安装不了lwqq,装不了下个源码自己编译居然还嫌它库老编译不了,这年头没有qq不行啊,wine弄的又不稳定总是崩溃,唉!

总结:centos的稳定适合装在服务器上,不适合办公等桌面平台。

没办法,折腾不起还躲不起么,决定换个系统。

(本人不大喜欢搞deb格式的包,另外在接触过的服务器系统中也都是红帽系列,rpm的,因此debian、ubuntu等不在考虑之内)

体验了下各个版本的linux,发现openSUSE还不错,装软件啥的有YaST也方便,下来装上了,可是才用了两天就发现问题。装个mysql-workbench,官方提供的版本自动解决依赖安装的,装完后居然缺少包启动不了,尼玛又是找库的工作,手动解决它,忍 了。

可是系统提示更新 ,在更新 之后居然好多软件起动不了了,连它系统自带的管理核心功能YaST都不能用了,以为是我乱弄包的问题,重装,直接更新系统,尼玛还是不能用,这也太不严谨了,果然用的人少不是没有道理 的,果断弃之。

 最后还是回到Fedora的怀抱,好几年没用这系统了,那会还版本还只到14呢,现在都20了,不过用起来还是挺顺手的,弄各种软件也方便,操作上跟centos没什么 区别,毕竟同一个系列嘛。

没意外的话,应该会fedora一直用下去了,牢骚雄起!!

你可能感兴趣的内容
CentOS 6.5下Git服务器搭建 收藏,2226 浏览
1条评论
9125015 1年前
就是个习惯问题,deb其实也不错,毕竟现在ubuntu用的人多

selfly

交流QQ群:32261424
Owner