为知笔记wiznote无法输入中文,fcitx输入法问题解决

分类: 其它 0人评论 1年前发布

linux下好用的云笔记客户端实在太悲催了,evernote、有道、等在windows下好用的都没有linux版,evernote倒有开源的第三方版,但是在试用之后发现速度老慢,而且在启动一会之后粘贴版就会无法使用,无奈放弃了。

最后发现了为知笔记,真是一大惊喜啊,之前在centos下安装了wiznote-1.5.16-6.3.x86_64.rpm版,挺不错的。

但是在使用fedora后,安装这个版本(kde桌面,yum里面的就是这个版本),同步都正常,但是界面真是惨不忍睹啊,可以说无法正常显示,没办法只能卸了。

发现网上有人打包的最新fedora 20的版本,wiznote-2.0.64-1.fc20.x86_64.rpm,下载后,安装

sudo rpm -ivh wiznote-2.0.64-1.fc20.x86_64.rpm

界面啥的都很好,很完美,但是在输入内容的时候,居然发现无法输入中文,自然也无法使用fcitx输入法,ibus就更不行了,网上查了一下,大意是这个版本的wiznote使用了qt5,而查看我的fcitx安装的是fcitx-qt4,必须安装fcitx-qt5模块才行。

yum里面搜了一下,只有fcitx-qt4,没有我需要的fcitx-qt5啊,没办法,网上找吧。

搜了一大堆,包括fcitx团队官方页面,都只有ubuntu的解决方案,fedora的没有。

弄了个其它linux的rpm包,安装发现需要一大堆依赖,去fedora的官网看了下这个qt5的基础fedora都已经是有了的,所以这个依赖肯定不对。

发现openSUSE的论坛上也有人碰到这个问题,下了个openSUSE版本的 fcitx-qt5-0.1.1-1.1.x86_64.rpm,安装,一切都很成功,但是打开wiznote,输入法仍然无法使用。

最后发现openSUSE论坛上有人用fcitx-qt5的源码包编译安装后,解决了问题,去openSUSE的官网查找了下,发现有个已经编译好的新版的fcitx-qt5,懒的自己编译,下载下来试试先。

下载的包版本:fcitx-qt5-0.1.1-4.1.x86_64.rpm,安装

sudo rpm -ivh fcitx-qt5-0.1.1-4.1.x86_64.rpm

重启fcitx,打开为知笔记,发现终于正常,可以使用了,不容易啊!

上一篇:
下一篇:

你可能感兴趣的文章

0 条评论